Cisco bridging

From Ever changing code
Jump to navigation Jump to search

This is another experimental page to record bridging functionality between 2 routed interfaces on a router. Used example is from GNS3, ios 12.4T, c3725, working.

Bridging-gns3
Bridging router - IRB
Current configuration : 2331 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool LAN
   network 10.0.10.0 255.255.255.0
   default-router 10.0.10.1
   dns-server 10.0.10.1 8.8.8.8
   domain-name lan.gateway
   lease 0 8
!
ip dhcp pool Management
   network 10.0.99.0 255.255.255.0
   default-router 10.0.99.100
   dns-server 10.0.99.100 8.8.8.8
   domain-name management.gateway
   lease 0 8
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
bridge irb
!
!
!
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 bridge-group 10
 bridge-group 10 spanning-disabled
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 bridge-group 20
 bridge-group 20 spanning-disabled
!
interface FastEthernet0/0.99
 encapsulation dot1Q 99 native
 bridge-group 99
 bridge-group 99 spanning-disabled
!
interface FastEthernet0/1
 no ip address
 speed 100
 full-duplex
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0/1.10
 encapsulation dot1Q 10
 bridge-group 10
 bridge-group 10 spanning-disabled
!
interface FastEthernet0/1.20
 encapsulation dot1Q 20
 bridge-group 20
 bridge-group 20 spanning-disabled
!
interface FastEthernet0/1.99
 encapsulation dot1Q 99 native
 bridge-group 99
 bridge-group 99 spanning-disabled
!
interface BVI1
 no ip address
!
interface BVI10
 ip address 10.0.10.1 255.255.255.0
!
interface BVI20
 ip address 10.0.20.1 255.255.255.0
!
interface BVI99
 ip address 10.0.99.100 255.255.255.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
cdp source-interface BVI99
!
!
!
!
!
!
control-plane
!
bridge 10 protocol ieee
bridge 10 route ip
bridge 20 protocol ieee
bridge 20 route ip
bridge 99 protocol ieee
bridge 99 route ip
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
Router as switch config (being bridged)
Current configuration : 1526 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 switchport trunk native vlan 99
 switchport trunk allowed vlan 1,10,20,99,1002-1005
 switchport mode trunk
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
interface Vlan99
 ip address 10.0.99.20 255.255.255.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

References