Cisco IOS load balaning

From Ever changing code
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

This will be applied to Cisco 1941/K9 platform having two WAN interfaces.

Gi0/0 - static public IP address
Dialer0 - static public IP address from BT Business ADSL connection

Configuration

This even has not been tested. It is just for reference purposes.

interface Gi0
 ip address 202.101.102.111 255.255.255.254
 ip nat enable
 ip virtual-reassembly
!
interface FastEthernet1
 no ip address
 pppoe enable
 no cdp enable
!
interface FastEthernet2
 no cdp enable
!
!
interface Vlan30
 description LAN Interface
 ip address 10.0.30.0 255.255.254.0
 ip nat enable
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!---Define LAN-facing interfaces with "ip nat inside".
!
Interface Dialer 0
 description PPPoX dialer
 ip address negotiated
 ip nat enable
 ip virtual-reassembly
 ip tcp adjust-mss 
!
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123
!
!
ip nat source route-map fixed-nat interface Dialer0 overload
ip nat source route-map dhcp-nat interface Gi0 overload
!
!--- Configure NAT overload (PAT) in order to use route-maps.
!
access-list 110 permit ip 10.0.10.0 0.0.1.255 any
!
!--- Define ACLs for traffic that are NATed to 
!--- the ISP connections.
!
route-map fixed-nat permit 10
 match ip address 110
 match interface Dialer0
!
route-map dhcp-nat permit 10
 match ip address 110
 match interface FastEthernet0
!--- Route-maps associate NAT ACLs with NAT outside on 
!--- the ISP-facing interfaces.

GNS3 test

This section is coming soooon.

References