Actions

Cisco 1941 with EHWIC-VA-DSL-M

From Ever changing code

Product codding

Cisco Multimode VDSL2 and ADSL2/2+ High-Speed WAN Interface Card

Product: EHWIC-VA-DSL-M
Description: 1-port VDSL2/ADSL2+ EHWIC over POTS with Annex M
Minimum IOS: 15.1(3)T

         VDSL2 (very high speed DSL)
        /  Digital Subscriber Line
       /  /
EHWIC-VA-DSL-M
 \      \     \Annex M
  \       ADSL2/A2+ (asymmetric DSL)
   Enhanced High-Speed WAN Interface Card
#show inventory
NAME: "CISCO1941/K9", DESCR: "CISCO1941/K9 chassis, Hw Serial#: FCZ012345JE, Hw Revision: 1.0"
PID: CISCO1941/K9      , VID: V05 , SN: ***********
NAME: "ADSL/VDSL over POTS Annex M supporting ADSL1, ADSL2, ADSL2+ and VDSL2 on Slot 0 SubSlot 1", DESCR: "ADSL/VDSL over POTS Annex M supporting ADSL1, ADSL2, ADSL2+ and VDSL2"
PID: EHWIC-VA-DSL-M    , VID: V01 , SN: ***********
Current platform info at the boot
Cisco CISCO1941/K9 (revision 1.0) with 487424K/36864K bytes of memory.
Processor board ID FCZ012345JE
1 DSL controller
1 Ethernet interface
2 Gigabit Ethernet interfaces
1 ATM interface
3 terminal lines
2 Cellular interfaces
DRAM configuration is 64 bits wide with parity disabled.
255K bytes of non-volatile configuration memory.
250880K bytes of ATA System CompactFlash 0 (Read/Write)

LED explained

LED Color Description
EN Green Operating system is running.
Amber Interface card is resetting.
Blinking System is initializing.
CD LED Green Lit when the unit is connected to the network and operating normally. On ADSL interface cards only, this LED blinks while training with DSLAMs.
LP LED Yellow DSL interface is in loopback mode.
Off Normal operation.

Config

! clean start by removing current config
erase startup-config _or_ write erase
reload
! initiate xDSL card, it's added automatically 
controller VDSL 0/1/0

o2 broadband configuration

o2 is one of this UK odd ISPs who is using RFC 1483 Bridge when providing ADSL2+ Internet access. Below are details provided by O2 and config build on this information.

ISP name: O2 Home Broadband  
Encapsulation: RFC 1483 Bridged
Multiplexing method: LLC-Based 
VPI: 0  
VCI: 101  
Username: leave blank  
Password: leave blank  
Domain name: leave blank  
IP address type: this depends on whether you chose our static IP address option or not:
    If you didn't choose our static IP address option, set this to dynamic IP
    If you did choose our static IP address, enter the IP address printed in your welcome letter  
DNS servers: choose to get these dynamically from the Internet provider  
NAT: enable  
Primary DNS server: 87.194.255.155  
Secondary DNS server: Leave blank 

If you have a static IP address, you should enter the following DNS server address:
Primary DNS server: 87.194.255.154
My o2 box MAC address: 00-24-17-11-22-33
A BVI (Bridged Virtual Interface)
is a virtual interface that acts like a normal routed interface. A BVI does not support bridging but actually represents the corresponding bridge group to routed interfaces. The interface number is the link between the BVI and the bridge group. Think of the BVI as the default gateway to all the bridge interfaces, all local traffic is bridged between the bridge interfaces, but the traffic that is not local to the bridge group is routed via the BVI interface. Read more on Cisco Community
Integrated Routing and Bridging
bridge irb command enables Integrated Routing and Bridging, then sub-interface atm0/1/0.1 and gi0/0 belong to the same Bridge Group 1 having both bridge-group 1 in their interface configurations. BVI1 (bridge virtual interface) is configured to represents both atm0/1/0.1 and gi0/0 interfaces when ip protocol is routed. Two lines at the bottom bridge 1 protocol ieee and bridge 1 route ip define the Bridge Group 1 is using IEEE bridge protocol and routes IP protocol.

Below config is working with O2 as of 8th Oct 2013, public ip address is provided by ISP dhcp server. Please see sub-interface atm0/1/0.1 command ip address dhcp therefore static ip route something like ip route 0.0.0.0 0.0.0.0 O2_gateway_ip is excluded. Please think about both commands when configuring static IP address given by O2.

! Last configuration change at 22:20:24 UTC Mon Oct 7 2013
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1-basic
!
boot-start-marker
boot-end-marker
!
!
enable secret cisco
!
no aaa new-model
!
ip cef
!
!
!
ip dhcp excluded-address 10.0.0.1 10.0.0.10
ip dhcp excluded-address 10.255.255.1 10.255.255.254
!
ip dhcp pool LAN
 network 10.0.0.0 255.0.0.0
 default-router 10.0.0.1
 dns-server 87.194.255.155 10.0.0.1
 domain-name lan.gateway
 lease 0 2
!
!
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1941/K9 sn **********
license accept end user agreement
license boot module c1900 technology-package securityk9 disable
license boot module c1900 technology-package datak9 disable
!
!
!
!
controller Cellular 0/0
!
controller VDSL 0/1/0
!
bridge irb
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 no ip address
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
 no mop enabled
 bridge-group 1
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ATM0/1/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no atm ilmi-keepalive
!
interface ATM0/1/0.1 point-to-point
 description Link to O2 Broadband
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 atm route-bridged ip
 pvc 0/101
  oam-pvc manage
  encapsulation aal5snap
 !
!
interface Ethernet0/1/0
 no ip address
 shutdown
!
interface BVI1
! o2 box's cloned mac address in case it's the only allowed to connect to ISP's DSLAM
 mac-address 0024.1711.2233
 ip address 10.0.0.1 255.0.0.0
 ip nat inside
 ip virtual-reassembly in
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 10 interface ATM0/1/0.1 overload
!
access-list 10 permit 10.0.0.0 0.255.255.255
!
!
snmp-server community contingency RO site
snmp-server enable traps entity-sensor threshold
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
!
line con 0
 logging synchronous
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line 0/0/0 0/0/1
 no exec
line vty 0 4
 password cisco
 logging synchronous
 login
 transport input all
!
scheduler allocate 20000 1000
!
end

Please notice that static ip route has been excluded because ip address and default gateway are optained from ISP dhcp server. Here default gateway is: S 82.132.253.115 [254/0] via 93.96.104.1, ATM0/1/0.1. This command is not needed for dynamic public IP address assignment via DHCP since that's the whole point of using DHCP. In other words, the default gateway should appear in routing table due to DHCP process with the ISP and not by manual configuration. The only time you need to manually configure the default gateway using DHCP is when you need to change the route administrative distance into something that fits your need. Should this be your choice, the command is the following:ip route 0.0.0.0 0.0.0.0 dhcp [ENTER NEW ADMINISTRATIVE DISTANCE HERE] Reference: Configure router with integrated ADSL modem as DHCP client

r1-basic#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 93.96.104.1 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 93.96.104.1
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, BVI1
L        10.0.0.1/32 is directly connected, BVI1
      82.0.0.0/32 is subnetted, 1 subnets
S        82.132.253.115 [254/0] via 93.96.104.1, ATM0/1/0.1
      93.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        93.96.104.0/21 is directly connected, ATM0/1/0.1
L        93.96.106.142/32 is directly connected, ATM0/1/0.1

BT ADSL2+

General settings for broadband modems/routers:

  • radius ppp username: broadband.user@btbroadband.com [provided by BT]
  • radius ppp password: it is not required as BT uses the phone number you're connecting via for authentication but if your router still shouts for one, use: 'BT', 'password', 'password1'
  • VPI number: 0
  • VCI number: 38
  • Authentication: CHAP
  • Modulation: G.DMT
  • Encapsulation: PPP over ATM (PPPoA); Virtual Circuit Multiplexing (VC-MUX)
  • Multiplexing: VC-based or VC Mux
interface ATM0/0/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ! The below command is deprecated. Use MFIB commands instead.
 no ip mroute-cache
 no atm ilmi-keepalive
 ! dsl operating-mode auto IOS12.4, in IOS15 this has been replaced to command .... in global config mode. But it is not necessary any more
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
interface Dialer0
 ip address negotiated '<-- or static IP --
 ! ip nat outside use this command in IOS12.4 and then remove one line below
 ip nat enable 
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ! fair-queue command is not available in IOS15
 ppp authentication chap callin
 ppp chap hostname bthomehub@btbroadband.com
 ppp chap password 0 anything
 ppp pap sent-username bthomehub@btbroadband.com password 0 anything
 ppp ipcp dns request
 no cdp enable
Experimental

PPP can insert a dynamic default route whenever IPCP negotiations succeed (and remove it when the line protocol goes down). To configure this feature (introduced in IOS releases 12.3(11)T and 12.4), use the ppp ipcp route default interface configuration command on the primary dialer interface.

ip route 0.0.0.0 0.0.0.0 Dialer0
to
interface Dialer0
ppp ipcp route default
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
! 'ip nat inside source list 1 interface Dialer0' overload use this in IOS12.4 and remove the line below
ip nat source list 1 interface Dialer0 overload
!
access-list 1 permit 10.0.0.0 0.0.255.255
dialer-list 1 protocol ip permit

BT Infinity

It usually the same connection to DSLAM but it uses different encapsulation. Therefore a dialer interface configuration it's similar to ADSL config.

  • VLAN: 101
  • VLAN encapsulation: dot1q
  • Authentication: CHAP (not confirmed)
  • Modulation: (not confirmed)
  • Encapsulation: PPP over Ethernet(PPPoE); Virtual Circuit Multiplexing (VC-MUX) (not confirmed)
  • Multiplexing: VC-based or VC Mux (not confirmed)
interface Dialer0
 description BT Infinity 40Mb down / 10 Mb upload
 mtu 1492
 ip address ip.add.re.ss m.a.s.k
 ! no ip redirects #removed due to causing VPN reconnection
 no ip unreachables
 no ip proxy-arp
 ip nat enable
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ntp disable
 ppp authentication pap chap ms-chap callin
 ppp chap hostname D******@hg52.btclick.com
 ppp chap password 0 ******
 ppp pap sent-username D******@hg52.btclick.com password 0 ******
 ppp ipcp dns request
 no cdp enable
interface ATM0/0/0
 no ip address
 shutdown
! BT Infinity - PPPoE, interface atm0/0/0 need to be shutdown
interface Ethernet0/0/0
 no ip address
!
interface Ethernet0/0/0.101
 encapsulation dot1Q 101
 pppoe enable group global
 pppoe-client dial-pool-number 1
Regerence

Troubleshooting

no debug ppp authentication
no debug ppp authorization
no debug ppp negotiation
no debug ppp subscriber
no debug pppoe events
no debug pppoe errors
no debug ppp error
no debug atm events 
show atm interface atm 0/0/0
Interface ATM0/0/0:
AAL enabled:  AAL5,, Maximum VCs: 8, Current VCCs: 1

VCIs per VPI: 1024,
Max. Datagram Size: 1658
PLIM Type: ADSL - 887Kbps Upstream, DMT, TX clocking: LINE
198286203 input, 1677750 output, 281727 IN fast, 149110058 OUT fast
 Avail bw = 887
Config. is ACTIVE
show atm pvc interface ATM 0/1/0
           VCD /                                            Peak Av/Min Burst
Interface  Name         VPI   VCI Type    Encaps     SC     Kbps   Kbps Cells St
0/1/0      2              0   101 PVC     SNAP       UBR    1261              UP
show atm pvc 0/101
Description: N/A
ATM0/1/0.1: VCD: 1, VPI: 0, VCI: 101
UBR, PeakRate: 1248 (2944 cps)
AAL5-LLC/SNAP, etype:0x0, Flags: 0x1840, VCmode: 0x0, Encapsize: 12
OAM frequency: 10 second(s), OAM retry frequency: 1 second(s)
OAM up retry count: 3, OAM down retry count: 5
OAM END CC Activate retry count: 3, OAM END CC Deactivate retry count: 3
OAM END CC retry frequency: 30 second(s),
OAM SEGMENT CC Activate retry count: 3, OAM SEGMENT CC Deactivate retry count: 3
OAM SEGMENT CC retry frequency: 30 second(s),
OAM Loopback status: OAM Received
OAM VC Status: Verified
OAM Loop detection: Disabled
ILMI VC status: Not Managed
VC is managed by OAM.
InARP DISABLED
High Watermark: 0, Low Watermark: 0
InPkts: 18967, OutPkts: 16369, InBytes: 20644554, OutBytes: 3278440
InPRoc: 1090, OutPRoc: 1635, Broadcasts: 1966
InFast: 17877, OutFast: 12768, InAS: 0, OutAS: 0
InPktDrops: 0, OutPktDrops: 0/0/0 (holdq/outputq/total)
CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0
Out CLP=1 Pkts: 0
OAM cells received: 872
F5 InEndloop: 872, F5 InSegloop: 0,
F5 InEndcc: 0, F5 InSegcc: 0, F5 InAIS: 0, F5 InRDI: 0
OAM cells sent: 872
F5 OutEndloop: 872, F5 OutSegloop: 0,
F5 OutEndcc: 0, F5 OutSegcc: 0, F5 OutAIS: 0, F5 OutRDI: 0
OAM cell drops: 0
Status: UP
show controllers atm 0/1/0
Interface: ATM0/1/0, Hardware: MPC ATMSAR, State: up
IDB: 0x30F78D2C  Instance: 0x29F3DBDC  PHY Inst: 0x00000000  us_bwidth: 1235
Slot:    0         Unit:     1         pkt Size: 4528
Sar ctrl queue: max depth = 0, current queue depth = 0,
                drops = 0, urun cnt = 0, total cnt = 0

VC TX ring stats:
VCD  VPI  VCI  Tx_ring_High_Watermark  Tx_ring_Low_Watermark   Queue_Depth
==========================================================================
1    0    101            128                124                0

VC QoS Summary
--------------
  Active            Scheduled
VCD VPI VCI  COS ST     COS       PCR(c)  PCR(a)  SCR/MCR(c)  SCR/MCR(a)
--------------------------------------------------------------------------
1    0   101   0        UBR       1235    1235    n/a         n/a

OAM statistics (vcd/count/drop)
-------------------------------
1/0/0  2/0/0  3/0/0  4/0/0  5/0/0  6/0/0  7/0/0  8/0/0

Misc Oam Drops: 0

ATM Encap Mapping
                                                Tx Congestion
Entry MAC address    VPI/VCI   VCD sts       set        clr     fastsend   safestart    drops
-----------------------------------------------------------------------------------------------
  0   c022.5000.0001  0/101     1   0          0          0        353       1363          0
show controllers vDSL 0/1/0
Controller VDSL 0/1/0 is UP

Daemon Status:           Up

                        XTU-R (DS)              XTU-C (US)
Chip Vendor ID:         'BDCM'                   'BDCM'
Chip Vendor Specific:   0x0000                   0xA1E9
Chip Vendor Country:    0xB500                   0xB500
Modem Vendor ID:        'CSCO'                   '    '
Modem Vendor Specific:  0x4602                   0x0000
Modem Vendor Country:   0xB500                   0x0000
Serial Number Near:    FOC012345WM 1941/K9 15.2(4)M
Serial Number Far:
Modem Version Near:    15.2(4)M
Modem Version Far:     0xa1e9

Modem Status:            TC Sync (Showtime!)
DSL Config Mode:         AUTO
Trained Mode:            G.992.5 (ADSL2+) Annex A
TC Mode:                 ATM
Selftest Result:         0x00
DELT configuration:      disabled
DELT state:              not running
Trellis:                 ON                       ON
SRA:                     disabled                        disabled
 SRA count:              0                       0
Bit swap:                enabled                         enabled
 Bit swap count:         1548                    7
Line Attenuation:        44.0 dB                 26.0 dB
Signal Attenuation:      44.4 dB                 25.6 dB
Noise Margin:             6.5 dB                  6.2 dB
Attainable Rate:        10056 kbits/s            1235 kbits/s
Actual Power:            19.1 dBm                12.1 dBm
Total FECC:             22362                    0
Total ES:               97                       1
Total SES:              0                        0
Total LOSS:             0                        0
Total UAS:              449                      449
Total LPRS:             0                        0
Total LOFS:             0                        0
Total LOLS:             0                        0

Full inits:             1
Failed full inits:      1
Short inits:            1
Failed short inits:     0

Firmware        Source          File Name (version)
--------        ------          -------------------
VDSL            embedded        VDSL_LINUX_DEV_01212008 (1)

Modem FW  Version:      120306_1254-4.02L.03.A2pv6C035j.d23j
Modem PHY Version:      A2pv6C035j.d23j
Vendor Version:         Ap6v35j.23j 68


                  DS Channel1     DS Channel0   US Channel1       US Channel0
Speed (kbps):             0             8644             0              1235
SRA Previous Speed:       0                0             0                 0
Previous Speed:           0                0             0                 0
Total Cells:              0        107787309             0          15380298
User Cells:               0             1874             0              3252
Reed-Solomon EC:          0            22362             0                 0
CRC Errors:               0              127             0                 1
Header Errors:            0              148             0                 0
Interleave (ms):       0.00             7.94          0.00              0.24
Actual INP:            0.00             2.00          0.00              0.00

Training Log :  Stopped
Training Log Filename : flash:vdsllog.bin

Ping atm interface command

Use the ping atm interface command to determine whether a particular PVC is in use. The PVC does not need to be configured on the router to use this command.

                                       Verifies PVC integrity to the      Verifies end-to-end
                                     immediate neighboring ATM device        PVC integrity
                                                  |                              | 
              end-to-end OAM echoes      segment OAM echoes          end-to-end OAM echoes
                                   \              |                 /
ping atm interface atm 0/0/0 0 38 {<cr> | seg-loopback | end-loopback}
                              \  \ 
                               \  vci value <1-1023> Virtual Channel Identifier
                                vpi value <0-31> Virtual Path Identifier

PVC - permanent virtual circuit
ATM - asynchronous transfer mode

Determining If a PVC Is in Use

r1#ping atm interface aTM 0/0/0 0 38 seg-loopback
Type escape sequence to abort.
Sending 5, 53-byte segment OAM echoes, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

This command sends five OAM F5 loopback packets to the DSLAM (segment OAM packets). If the PVC is configured at the DSLAM, the ping is successful.

r1#ping atm interface aTM 0/0/0 0 38 end-loopback
Type escape sequence to abort.
Sending 5, 53-byte end-to-end OAM echoes, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Please note that ATM OAM Ping Feature returns unsuccessful ping on BT-ADSL line. I am not sure about others.

SNR and Line Attenuation

SNR is Signal to Noise Ratio ** (aka Noise Margin or Signal to Noise Margin)

Relative strength of the DSL signal to Noise ratio. 6dB is the lowest dB manufactures specify for modem to be able to synch. In some instances interleaving can help raise the noise margin to an acceptable level. The higher the number the better for this measurement. The lower the SNR, the louder noise is on your line in comparison to the ADSL signal, so higher SNR is always better. Low SNR doesnt always mean low speed, more often than not it causes reliability issues, but depending on just how bad the noise is, it can eat away at subcarriers, which will lower your overall speed

  • 6dB or below is bad and will experience no synch or intermittent synch problems
  • 7dB-10dB is fair but does not leave much room for variances in conditions
  • 11dB-20dB is good with no synch problems
  • 20dB-28dB is excellent
  • 29dB or above is outstanding
Loop Att. is Line Attenuation

Measure of how much the signal has degraded between the DSLAM and the modem. Maximum signal loss recommendation is usually about 60dB. The lower the dB the better for this measurement.

  • 20dB and below is outstanding
  • 20dB-30dB is excellent
  • 30dB-40dB is very good
  • 40dB-50dB is good
  • 50dB-60dB is poor and may experience connectivity issues
  • 60dB or above is bad and will experience connectivity issues
Output Power

How much power modem (upstream) or DSLAM (downstream) is using. Maximum recommended is about 15dB. The lower the power the better for this measurement.

DSL routers, in addition to the actual SNR, may define signal-to-noise margin (SNR margin) as the difference between the actual SNRand the SNRrequired to sync at a specific speed. For example:

actual SNR = 44dB
SNR to sync at 8Mbit/s = 35dB
SNR margin = 44-35= 9dB

As with actual SNR, the higher that SNRmargin number, the better and above 6dB is acceptable.

SNR Adjustment for Stability

Go into global configuration mode and type the following:

service internal
int atm 0
dsl noise-margin (a value between -3 and 3)

The service internal command exposes the dsl noise-margin command (and other hidden/non standard commands). The dsl noise-margin forces the router to training at a higher noise margin (sacrificing speed for stability). Setting this to 3 for example should see you get a higher noise margin, slower speed (and depending on firmware) a higher attenuation. Start at 3 and work your way down to 0 in 0.5 steps until you get a stable connection. A value of 0 is the same as not having this command at all (eg: normal settings). If you add a dsl noise-margin command, after a reload you’ll see “WARNING: Unsupported Command. May cause violation to ADSL standards.” on bootup, ignore it, it’s just the addition of the noise-margin command. Use the dsl noise-margin command to fine tune your connection to get that extra stability if required.

Cacti logging

Cacti ADSL template

Interleaving

When a customer is put on a "Noise Profile" usually their DSL line is changed from FastPath to Interleaved.

Interleaving is an error correction protocol that is implemented for your line at the DSLAM. With Interleaving enabled, the DSLAM can correct errors in the data stream it receives before passing that data to your gateway router. It is usually implemented on noisy or marginal lines and can greatly increase sync stability and effectively eliminate "first hop" packet loss. The largest drawback to Interleaving is that it will increase your ping time, specifically to your first hop gateway router.

If Interleaving is not enabled on your line, it is configured as FastPath. FastPath allows the DSLAM to pass the data received from you to the first hop router without performing any error correction. As a result, marginal lines could experience an increase in packet loss and decrease in sync stability (i.e. frequent sync loss). However, FastPath has lower ping times, especially to the first hop router.

show controllers vDSL 0/0/0
Controller VDSL 0/0/0 is UP

Daemon Status:           Up

                        XTU-R (DS)              XTU-C (US)
Chip Vendor ID:         'BDCM'                   'IFTN'
Chip Vendor Specific:   0x0000                   0x71C8
<-- output ommitted -->
 Bit swap count:         3348                    15
Line Attenuation:        55.5 dB                 25.8 dB
Signal Attenuation:      61.5 dB                 26.0 dB
Noise Margin:             3.1 dB                  6.7 dB
Attainable Rate:        4840 kbits/s             896 kbits/s
Actual Power:             0.0 dBm                12.8 dBm
Total FECC:             552456                   33948
<-- output ommitted -->
                  DS Channel1     DS Channel0   US Channel1       US Channel0
Speed (kbps):             0             4046             0               876
SRA Previous Speed:       0                0             0                 0
Previous Speed:           0             4331             0               895
Total Cells:              0        546032971             0         117935394
User Cells:               0        135787856             0          35293248
Reed-Solomon EC:          0            57489             0               508
CRC Errors:               0             4950             0              2483
Header Errors:            0              725             0                72
Interleave (ms):       0.00             7.97          0.00              5.93
Actual INP:            0.00             1.16          0.00              0.41
<-- output ommitted -->

Friendly Advice/Time Saver: Even though you may (after a large amount of effort) be able to call the Helpdesk and get switched to Fastpath, there's usually a reason you are interleaved, so you may or may not be able to connect without it. Typically, the system will automatically switch back to interleaved after a short time anyway.

References

DSL Troubleshooting
ISP configs
Other