Actions

Cisco 1941 with EHWIC-4G-LTE-G

From Ever changing code

Product codding

Cisco Fourth-Generation (4G) Long-Term Evolution (LTE) Wireless WAN (WWAN) Enhanced High-Speed WAN Interface Card

Product: EHWIC-4G-LTE-G
Description: 4G WWAN EHWIC - Global Multimode LTE/DC-HSPA+/HSPA+/HSPA/UMTS/EDGE/GPRS
Minimum IOS: Mainline Cisco IOS Software Release 15.2(4)M3 
             with Modem Firmware 3.5.x or later IOS Release with respective Modem Firmware
          
            Long-Term Evolution (LTE) Wireless WAN (WWAN)
           /    Multimode LTE for all global LTE carriers (Global SKU) that operates LTE on             
          /   /       800-MHz, 900-MHz, 1800-MHz, 2100-MHz or 2600-MHz networks (Europe)
EHWIC-4G-LTE-G
 \     \
  \     Fourth-Generation (4G)
   Enhanced High-Speed WAN Interface Card
#show inventory
NAME: "CISCO1941/K9", DESCR: "CISCO1941/K9 chassis, Hw Serial#: FCZ1735C0RA, Hw Revision: 1.0"
PID: CISCO1941/K9      , VID: V05 , SN: ******(x11)
NAME: "4G WWAN EHWIC - Global Multimode LTE/DC-HSPA+/HSPA+/HSPA/UMTS/EDGE/GPRS on Slot 0 SubSlot 0", DESCR: "4G WWAN EHWIC - Global Multimode LTE/DC-HSPA+/HSPA+/HSPA/UMTS/EDGE/GPRS"
PID: EHWIC-4G-LTE-G    , VID: V01 , SN: ******(x11)
NAME: "Modem 0 on Cellular0/0/0", DESCR: "Sierra Wireless MC7710 4G-G"
PID: MC7710            , VID: 10 , SN: *******IMEI(x15)
NAME: "4 Port GE POE EHWIC Switch on Slot 0 SubSlot 1", DESCR: "4 Port GE POE EHWIC Switch"
PID: EHWIC-4ESG-P      , VID: V01 , SN: ******(x11)

LED explained

LED Color Description
WWAN Solid green Indicates the modem is receiving power and is associated and authenticated but not receiving or transmitting data.
Fast green blink Indicates the modem is receiving power and is associated and authenticated. The blink rate is proportional to the transmitted and received data rate.
Slow green blink Indicates the modem is receiving power but is not associated or authenticated and is searching for service. Check the antenna, cable, SIM card, or the user account with your service provider.
Off Indicates the modem is in reset mode.
RSSI Solid green Indicates a high RSSI (greater than -69 dBm).
Medium green blink Indicates a medium-level RSSI (from -89 dBm to -69 dBm).
Slow green blink Indicates a low-level RSSI (from -99 dBm to -89 dBm).
Off Indicates the RSSI is less than -99 dBm. Check for proper antenna attachment. Adjust antenna placement and orientation.
Solid amber Indicates no service is detected. Relocate the equipment.
HSPA+ Solid green Indicates HSPA+ is in service.
Off Indicates that a non-HSPA+ is in service or that there is no service.
LTE Solid green Indicates LTE is in service.
Off Indicates LTE service is not being used.
GPS Solid green Indicates the GPS is active.
Off Indicates the GPS is not active or not detected.

Antenna and cable

Cisco Product Number Description Cable Length Maximum Insertion Loss (cable) or Maximum Gain (antenna) Frequency (MHz) Color
4G-AE010-R Extension base with integral 10-foot cable 10 ft (3 m) 1.4 dB @ 700 MHz, 2.0 dB @ 1.9 GHz, 2.1 dB @ 2.1 GHz, 2.3 dB @ 2.5 GHz, 2.4 dB @ 2.7 GHz 700-2600 MHz Black
4G-LTE-ANTM-D Indoor 4G dipole omnidirectional na 2 dBi 698-806 MHz, 824-894 MHz, 925-960 MHz, 1710-1885 MHz, 1920-1980 MHz, 2110-2170 MHz, 2500-2690 MHz Black
4G-ANTM-OM-CM 4G Indoor Ceiling-Mount Omnidirectional Antenna na 700-960 MHz (1 and 1.5 dBi), 1700-2200 MHz (1.7 and 3.2 dBi), 2500-2700 MHz (3 and 4 dBi) 3G or 4G bands, 698 MHz-2690 MHz White

Configuration

This configuraton relays on EHWIC-3G-HSPA+7 configuration therefore not all trouble shooting steps are included here. For deep deep dive trouble shooting please refere to EHWIC-3G-HSPA+7 config page or references links.

Configure APN profile

APN configuration is stored on the modem nvram not on the router it self. Cisco IOS provides interface to manipulate the modem and modem profiles with following syntax:

cellular 0/0/0 lte create profile create 1 <apn name> chap <username> <password> ipv4

Use the command below to configure Vodafone contract profile:

cellular 0/0/0 lte profile create 1 internet chap web web ipv4

Define AT command in a chat-script

Chat script should be applied in global config mode. Please remember that dialer name is a case sensitive. Syntax

chat-script script-name "" "AT!CALL1" TIMEOUT timeout-value "OK"

Command to apply:

chat-script LTE "" "AT!CALL1" TIMEOUT 20 "OK"

You can manually execute the chat script if needed for debugging purposes. Here LTE is the chat-script name and 0/0/0 is cellular interface

start-chat LTE 0/0/0

Configure line interface

This line interface information sets low-speed asynchronous “control” interface which communicates with the modem. The line x/x/x number is the same as cellular x/x/x interface number.

Issue show line to find out what TTY line number is used to communicate with the modem

#sh line
   Tty Line Typ     Tx/Rx    A Modem  Roty AccO AccI  Uses  Noise Overruns  Int
*     0    0 CTY              -    -      -    -    -     0      0    0/0      -
      1    1 AUX   9600/9600  -    -      -    -    -     0      0    0/0      -
      2    2 TTY   9600/9600  -    -      -    -    -     0      0    0/0      -
I 0/0/0    3 TTY              - inout     -    -    -     0      0    0/0    Ce0/0/0
    132  132 VTY              -    -      -    -    -     0      0    0/0      -
Line(s) not in async mode -or- with no hardware support:
4-131
! This will depend on what slot the 4G card uses
line 0/0/0			
 exec-timeout 0 0
 ! Calls the chat-script
 script dialer LTE
 ! activates the script it did not work without it for GSM card. Not tested fir LTE card. 
 script activation LTE	
 modem InOut
 no exec

!Note - previously used on EHWIC-3G-HSPA+7 card, commands rxspeed 21600000 and txspeed 5760000 here on line 0/0/0 have no effect; we should use modem AT commands instead. These will be defaulted to rxspeed 100000000 and txspeed 50000000

Configure the Cellular interface, NAT and cellular routing

Local lan is connected to Gi0/1 and all traffic is NAT overload'ed through Cellular0/0/0 interface. There ip 10.0.30.1 is a default gateway for local LAN hosts. From IOS 15 ip nat inside / ip nat outside legacy commands can be replaced by ip nat enable. Please visit NVI - NAT Virtual Interface.

Standard DDR Config with dialer idle-timeout

Below is standard config for DDR, where dialer monitors idle time and will bring Cellular interface down when no interested traffic is detected. This is for the subscription plan with number of minutes and data allowance. !Note: if Cellular interface goes down it will not resolve DNS request resulting with no interesting traffic detection and it will not bring interface up.

interface GigabitEthernet0/1
 ip address 10.0.30.1 255.255.254.0
 ip nat enable
 duplex auto
 speed auto
!
interface Cellular0/0/0
 description WAN link to Vodafone-APN
 ! --- The NAS will issue your card with IP address
 ip address negotiated 	
 ip nat enable
 ! --- it is not recommended 'virtual-reassembly' for US Verizon, not sure about Vodafone but it is not included in default config from Cisco
 ! --- new modem cards are using native slip protocol to communicate with the router
 encapsulation slip
 ! --- enables DDR and configures the specified serial interface to use in-band dialing. 
 dialer in-band
 ! --- specify idle timeout before disconnecting line, 0 always on
 dialer idle-timeout 180
 dialer string LTE
 ! --- this is reference to a dialer-list <number> of interesting traffic.
 ! --- it specifies the number of the dialer access group to which the specific interface belongs. 
 dialer-group 1
 async mode interactive
!
ip forward-protocol nd
!
ip nat source list 2 interface Cellular0/0/0 overload
! --- Static route to cellular interface required by Cisco for the proper packet routing
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0 
!
access-list 2 permit any 
! --- creates a dialer list for traffic of interest this permitted  traffic will bring the Cellular interface up
dialer-list 1 protocol ip permit
Verify idle timer
#show dialer
Ce0/0/0 - dialer type = IN-BAND ASYNC NO-PARITY
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=10.0.10.1, d=8.8.8.8)
Time until disconnect 117 secs
Current call connected 00:00:18
Connected to LTE

Dial String      Successes   Failures    Last DNIS   Last status
LTE                      3          0    00:00:18       successful   Default

Dialer Persistent Configuration always ON

Dialer interface here Cellular 0/0/0 will be always on. It is good for unlimited data/minutes subscriptions. For reference please check Cisco Software Installation Guide

Option 1. Setting up idle timer to indefinite

Add dialer idle-timeout 0 command under Interface Cellular 0/0/0.

#show dialer
Ce0/0/0 - dialer type = IN-BAND ASYNC NO-PARITY
Idle timer (never), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=10.0.10.1, d=8.8.8.8)
Time until disconnect never
Current call connected 00:00:09
Connected to LTE

Dial String      Successes   Failures    Last DNIS   Last status
LTE                      4          0    00:00:09       successful   Default
Option 2. Dialer-Persistent Configuration with External Dialer Interface

The only option to tear down a call is to shutdown Dialer 1 interface.

chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
interface Cellular0/0/0
 description WAN link to Vodafone-APN
 ip address negotiated
 encapsulation slip
 dialer in-band
 dialer pool-member 1
 async mode interactive
 routing dynamic
! 
interface Dialer1
ip address negotiated
ip nat enable
encapsulation slip
! --- Specifies the dialing pool to use for calls to this destination
 dialer pool 1
 dialer idle-timeout 0
 dialer string LTE
 ! --- Forces a dialer interface to be connected at all times, even in the absence of interesting traffic
 dialer persistent
 ! --- Assigns the dialer interface to a dialer group
 dialer-group 1
!
ip nat source list 2 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 2 permit any 
dialer-list 1 protocol ip permit
Verify - Dialer-Persistent Configuration with External Dialer Interface.

Output below has been snapped when connected to Vodafone contract profile.

R1#show dialer interface dialer 1
Di1 - dialer type = DIALER PROFILE
Idle timer (never), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Number of active calls = 1

Dial String      Successes   Failures    Last DNIS   Last status
LTE                      1          1    00:00:51       successful   Default

Ce0/0/0 - dialer type = IN-BAND ASYNC NO-PARITY
Dialer pool 1, priority 0
Idle timer (never), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Persistent Dialer Profile
Interface bound to profile Di1
Time until disconnect never
Current call connected 00:00:51
Connected to LTE
R1#show dialer
Ce0/0/0 - dialer type = IN-BAND ASYNC NO-PARITY
Dialer pool 1, priority 0
Idle timer (never), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Persistent Dialer Profile
Interface bound to profile Di1
Time until disconnect never
Current call connected 00:08:56
Connected to LTE

Di1 - dialer type = DIALER PROFILE
Idle timer (never), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Number of active calls = 1

Dial String      Successes   Failures    Last DNIS   Last status
LTE                      1          1    00:08:56       successful   Default
R1#show interfaces dialer 1
Dialer1 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Internet address is 10.16.73.151/32
  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 9/255, rxload 255/255
  Encapsulation SLIP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Interface is bound to Ce0/0/0
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 01:08:28
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 163000 bits/sec, 13 packets/sec
  5 minute output rate 2000 bits/sec, 7 packets/sec
     8206 packets input, 9551482 bytes
     7107 packets output, 2615106 bytes
Bound to:
Cellular0/0/0 is up, line protocol is up
  Hardware is 4G WWAN EHWIC - Global Multimode LTE/DC-HSPA+/HSPA+/HSPA/UMTS/EDGE/GPRS
  Description: WAN link to Vodafone-APN
  Internet address will be assigned dynamically by the network
  MTU 1500 bytes, BW 50000 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation SLIP, loopback not set
  Keepalive not supported
  Interface is bound to Di1 (Encapsulation SLIP)
  Last input 00:00:02, output 00:00:02, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/10 (size/max)
  5 minute input rate 236000 bits/sec, 29 packets/sec
  5 minute output rate 69000 bits/sec, 22 packets/sec
     8245 packets input, 9554366 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     7137 packets output, 2618090 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
Option 3. (bonus) It is using dialer watch-list command

Below are included a few lines from the optional dialer watch-list option, these are only included because of the very clear comments included. Potentially these could be used to develop to full config.

!### The call will be triggered by this statement. The address “5.6.7.8” is a “dummy” route. Any “dummy” value can be used. ###
dialer watch-list 1 ip 5.6.7.8 0.0.0.0
!### ISR will wait 60 sec. to activate the call after the initial boot. ###
dialer watch-list 1 delay route-check initial 60
!### The router will wait 1 sec. before activating the call. ###
dialer watch-list 1 delay connect 1

Troubleshooting

  • debugging of persistent dialer profile
#debug dialer
Di1 DDR: Persistent Dialer Profile nailed up successfully
  • clear interface

When dialer persistent is configured, the clear interface command clears unsuccessful dial attempts on a line without interesting traffic, and then the dialer software attempts to bring up the connection as persistent.

Router# clear interface 
  • Shutting Down an Interface Configured for Dialer Persistence

Fully tears down a persistent connection and prevents the software from attempting more dialing.

R1(config)# interface dialer 1
R1(config-if)# shutdown

Tests

Results speedtest.net:

  • RSSI: -81 dBm, 2 diversity antennas, 4G card
    • Location: nn160qr@22:00 on 2/11/2013
    • ping: 69ms, DL 7.05Mbps, UL 1.19Mbps
  • RSSI: -77~81 dBm, 2 diversity antennas, 4G card
    • Location: nn160qr@12:00 on 3/11/2013
    • ping: 70ms, DL 3.30Mbps, UL 0.68Mbps
  • RSSI: -78~81 dBm, 1 diversity antennas, 4G card
    • Location: nn160qr@12:05 on 3/11/2013
    • ping: 86ms, DL 3.85Mbps, UL 2.05Mbps
  • RSSI: -78~81 dBm, 0 no antennas, 4G card
    • Location: nn160qr@12:07 on 3/11/2013
    • ping: na ms, DL 0Mbps, UL 0Mbps
Conclusion

Diversity antenna does not improve significantly the link quality

sh cellular 0/0/0 radio command on 4G-LTE card does not include Service Provider (like Vodafone) in stats

R1#sh cellular 0/0/0 radio
Radio power mode = ON
Current RSSI = -81 dBm
LTE Technology Preference = AUTO
LTE Technology Selected = UNKNOWN
R1#sh cellular 0/0/0 ne
R1#sh cellular 0/0/0 network
Current Service Status = Normal
Current Service = Packet switched
Current Roaming Status = Home
Network Selection Mode = Automatic
Mobile Country Code (MCC) = 234
Mobile Network Code (MNC) = 15
Packet switch domain(PS) state = Attached
Registration(EMM) state = Registered

References